1. Everything Android is a community forum that makes it easy to ask questions about anything and everything Android. It's 100% free and no registration required (though we think it would be awesome if you joined our community). Our community of experts are here to help.
    Dismiss Notice

Can't play videos from sd card

Discussion in 'Android Questions' started by CillaC, Jan 6, 2014.

  1. CillaC

    CillaC New Member

    Jan 6, 2014
    0

    Sponsored Ad

    I got my son a tablet for Christmas. I love it. I recently got an 8gb sd card and put movies on it. Some were .avi files and others were .mp4 files. The ones I put on the internal storage work great. When I first mounted the sd card I noticed that some of the apps stored in the internal sd quit working. Restarted it, everything was fine. (any idea why that is?) Put movies on the sd card and noticed some I could fast forward and others I couldn't. Shortly after I realized those that wouldn't allow me to fast forward would only play 10 min of the movie then a msg would pop up "Unable to play Video". After playing with it for a while i re-converted some movies, wiped the sd card, mounted it, restarted the tablet (due to the apps stored on internal sd not reading), then added the movies. Viola! Everything worked great. All movies worked. I could fast forward. At the end of the day my son comes to me because his movie quit playing after 10 min. I messed with it for a bit and realized I was back at square 1. All videos quit playing the exact spot they did before. Any suggestions please. I've tried other video players and nothing works. Any feedback is appreciated.

    Sent from my SPH-L710 using Everything Android mobile app
     
  2. stevetaz

    Moderator

    Sep 23, 2008
    87
    Not sure what you mean when you say "mounted the SD Card". Also, before loading anything on the card did you format it in the tablet?

    Also, please provide the tablet brand, model and OS version it is running.
     
  3. Sponsored Advertisement

  4. CillaC

    CillaC New Member

    Jan 6, 2014
    0
    It is a Visual Land Prestige Pro 7d tablet. I always format my card in my devices but the option wasn't there. When I say "mounted" and "unmounted" look in the settings under storage. I believe most android devices have this to safely remove the sd card. When you put an sd card in you press "mount sd card" for the device to read all of its contents. When you remove it you are supposed to "unmount the sd card" first.

    Sent from my SPH-L710 using Everything Android mobile app
     
  5. CillaC

    CillaC New Member

    Jan 6, 2014
    0
    Running on 4.1

    Sent from my SPH-L710 using Everything Android mobile app
     
  6. stevetaz

    Moderator

    Sep 23, 2008
    87
    Off the top of my head I can't think of a reason, but obviously there is an issue.

    The option to format the card wasn't there, where? I do not have an Android tablet so I am asking out of ignorance. I have the option on my Android phone under Storage. Do you mean when the card is inserted into the slot? From what I am reading the option to format a card is not present in Android tablets. Hmmmm....

    Are you using the native player that came with the device? Have you tried downloading and installing a third-party player from the Play Store?

    I will do some more investigating, but one thought is to contact support at the manufacturer if you just got this at Christmas. They should be able to help you quickly and efficiently....Their contact info should be a part of the documentation that came in the box.
     
  7. knuckles1978

    knuckles1978 New Member

    Mar 10, 2013
    0
    Try MX Player, it's the best video player there is for android.

    Sent from my GT-I9000 using Tapatalk
     
  8. maryjane0106

    maryjane0106 New Member

    Jun 15, 2014
    0
    check will maybe your storage already full , or have a virus .
     
  9. scarhart

    scarhart New Member

    Jul 28, 2014
    0
    This sounds like the same problem I have with my Akuso W100. Basically, there is not enough RAM in the tablet to allow sufficient caching to allow your video to play. I can play videos from my internal storage just fine, but the same file will not play from the SD card. This just seems to be a pitfall of buying a cheap tablet. I have returned my W100 and am waiting for my new Toshiba Excite Pure to arrive. It costs $199 instead of $104.95, but it has 16GB of internal storage instead of Akuso's 8GB (which turned out to actually be 2.51GB.) as well as a microSD card slot, and a quad-core Tegra processor. We'll see if I still have the same problems with this one.
     
  10. nilofar shaikh

    Bronze

    Oct 20, 2015
    0
    check will maybe your storage already full , or have a virus in it..
     
  11. BrianRobins

    Bronze

    Oct 9, 2015
    1
    Yeah i think your storage is already full or it needs to clean a virus.
     

Share This Page