1. Everything Android is a community forum that makes it easy to ask questions about anything and everything Android. It's 100% free and no registration required (though we think it would be awesome if you joined our community). Our community of experts are here to help.
    Dismiss Notice

Email not working on Wi-Fi

Discussion in 'Android Questions' started by markaevans1975, Sep 25, 2012.

  1. markaevans1975

    markaevans1975 New Member

    Sep 25, 2012
    0

    Sponsored Ad

    When I am connected to Wi-Fi on my Droid 4 I am able to receive email for a while and then it just stops. As soon as I turn Wi-Fi OFF and use the cellular connection email starts flowing again. If I turn Wi-Fi back on, email will work for a while (sometimes hours, sometimes days) and then stop again.

    I would like to be able to use email on Wi-Fi without having to constantly turn Wi-Fi on and off.

    I have read several forum posts online about Android users with the same problem.

    I am connecting to a corporate Exchange account. My network admin has confirmed when connected to corporate Wi-Fi all packets are internal and there is no limitation on the number of Active Sync connections. For some reason the phone has an internal Wi-Fi but AS seems to want to connect from the outside.

    Does anyone have a fix? Is this a known issue and if so, is someone working on a patch for it?
     
  2. stevetaz

    Moderator

    Sep 23, 2008
    87
    First, please specify which OS you are running and if the device is stock, rooted, custom ROM, etc.

    Second, is this something that used to not be a problem, but just started or has it been that way since day one?

    Third, when you say you are connected to WiFi, is this in a home, a business, an open connection, one that you have to enter a key to access, across multiple types of connections, etc?

    What do you mean the Active Sync wants to connect from the outside? Is the device terminating a session and searching for alternate connections?

    How many different WiFi connections are stored in your device?
     
  3. Sponsored Advertisement

  4. markaevans1975

    markaevans1975 New Member

    Sep 25, 2012
    0
    The device is running ICS 4.0.4.

    Maintaining a stable connection to the email server has been a problem since day 1 and I have had the same issue on 4 different Droid 4 phones.

    Our mail server has an external and internal IP address. The Wi-Fi I am referring to is at work. When I am outside the office connected to Wi-fi at my house or anywhere other than work, email works fine. When I connect to Wi-Fi at work email works for a while and then stops synching. When I refresh the active sync settings I can see that although the phone has an internal IP address on our Wi-Fi network, AS is trying to connect to the external mail server IP instead of the internal.

    When I turn Wi-Fi off at work and use cellular only, there is no problem. Probably because the phone is only ever using the external mail address to connect.

    I have 4 Wi-Fi connections stored on the device.
     
  5. stevetaz

    Moderator

    Sep 23, 2008
    87
    Is the External IP listed above your Internal IP in the listing? Do others have the same issue and if so are they also using a Droid or another phone/OS?
     
  6. markaevans1975

    markaevans1975 New Member

    Sep 25, 2012
    0
    Which listing are you referring to?

    The only other person having this issue is the other Droid 4 user. Nobody else using an Android or iOS device has this problem. Obviously some email delays are expected over Active sync but the Droid 4s are the only devicewhere email push stops completely.
     
  7. stevetaz

    Moderator

    Sep 23, 2008
    87
    Is there a "Sleep Policy" set for the Droids? I am on GB, but you should have it in the Settings somewhere. Settings > WiFi Settings > Menu Button > Advanced > Wi-Fi Sleep Policy > set to NEVER. Sounds like if you connect, but only for a time maybe there is a timer set and the Sleep policy does that. I noticed Scott had helped another member out here at eA when his tablet was losing the WiFi connection and it was because of the sleep setting.

    What I mean by listing is when you open up your WiFi Settings and it scans the various networks you have remembered appear in a list. In theory the strongest signal should appear first even if it is one you have not connected to. Sometimes they get flummoxed and deleting then readding can help too.
     

Share This Page