My computer doesn't recognize my phone through a USB connection

Discussion in 'Android' started by ioklun, Dec 15, 2010.

  1. ioklun

    ioklun New Member

    Joined:
    Dec 15, 2010
    Likes Received:
    0
    I'm trying to connect my phone to my computer via a USB connection, which I have done several times before. However, my computer is no longer detecting my phone. I do see that the battery gets recharged, but unlike before, my phone no longer prompts me if I want to mount the phone to transfer files. My computer also doesn't list it as a connected USB device.

    I have an HTC myTouch 3G, and it recently updated to Android 2.2.1. Actually, I don't remember having this problem before the update, so that may be what's causing the problem.

    The reason I'm trying to connect the phone is that I'm doing some Android development and would like to deploy an app to my physical phone. I'm working on Windows 7 (64 bit), but I'm trying to deploy from Ubuntu 10.10 through VMWare. I don't know if that's important, but neither VMWare nor Windows detects my phone. I've even tried on my laptop and I get nothing. I think it's something to do with the phone.

    I've searched everywhere but I can't find a solution to the problem. Any ideas as to what could be the problem?
     
    #1
  2. bberryhill0

    Silver

    Joined:
    Feb 14, 2009
    Likes Received:
    0
    Does the phone show that you are connected in notifications?

    Have you tried a different cable?

    Swyped from my Eris running xtrSense 3.
     
    #2
  3. Avatar

    Sponsored Advertisement

  4. ioklun

    ioklun New Member

    Joined:
    Dec 15, 2010
    Likes Received:
    0
    No my phone doesn't notify me of anything. I also tried a different cable, and I get the same thing.
     
    #3
  5. My-Droid

    Bronze

    Joined:
    Jun 16, 2010
    Likes Received:
    2
    If you do not have this issue fixed, then you might take you phone for repair. Apparently, it is not a driver issue or a cable issue in W7. It may be a software issue with your phone.

    I am running Ubuntu 10.10 on dual boot. I am running Android 2.2.1 on my Droid. I'll see if there is an issue and get back to you in a bit.
     
    #4
  6. My-Droid

    Bronze

    Joined:
    Jun 16, 2010
    Likes Received:
    2
    You are going to have to take your phone in for repair. I am in Ubuntu 10.10. My phone is charging. When I plugged my phone in, it was recognized and F-spot came right open. From "Places," I was able to browse all the folders in my phone. NO NEED FOR VMWARE.
     
    #5
  7. ioklun

    ioklun New Member

    Joined:
    Dec 15, 2010
    Likes Received:
    0
    I haven't fixed the issue so I would appreciate it if you did get back to me. I've kind of given up and settled on working with the Android emulators for now, but I during my search I remember seeing some threads that suggested reimaging the phone. They were a couple of years old though, so I didn't know if that applied. I might have to give that a try though.
     
    #6
  8. ioklun

    ioklun New Member

    Joined:
    Dec 15, 2010
    Likes Received:
    0
    Good to know. Thanks for the help.
     
    #7

Share This Page