1. Everything Android is a community forum that makes it easy to ask questions about anything and everything Android. It's 100% free and no registration required (though we think it would be awesome if you joined our community). Our community of experts are here to help.
    Dismiss Notice

Samsung Galaxy S GT i9000 internal sd card not working and touchscreen not responding.

Discussion in 'Android Questions' started by rmlc, Aug 20, 2012.

  1. rmlc

    rmlc New Member

    Aug 20, 2012

    Sponsored Ad

    Hi. I have a Samsung galaxy S i9000 running a Jellybean 4.1 custom ROM. (http:// androidadvices. com/update-galaxy-gt-i9000-stable-jellybean-411-firmware/#.UDHz6t1mT9c)

    Everything's working fine until today when my laptop (Win7 OS) froze up while I was formatting the internal sd card of my phone.I restarted the laptop and phone and the internal sd card cannot be detected by either device anymore.

    I tried to format the sd card multiple times to no avail. I tried to flash stock GB ROM. ODIN can detect the phone but cannot complete the process. It fails on "Setting Up Connection".

    Up to the above process I was able to use my phone (it turns itself on, just can't use internal sd card). However, I made a stupid mistake of doing factory reset, cache wipe, and dalvik cache to reflash the JB ROM in hopes that it will fix it. Now, my phone is stuck on the Welcome screen (one with Choose Language and Start to setup) but the touchscreen isn't working so I can't select Start. The buttons on either side of the center button works, though. Only the touchscreen function is not working.

    Now obviously, USB Debugging is not set up on my phone so I can't do a lot. My first question is: Is there a way to setup USB Debugging using ADB or from Recovery?

    Additional info:
    Recovery and Download mode are both working, although like I mentioned above, I cant reflash stock ROM because of no usb debugging and it fails in Odin. File Manager can be accessed from Recovery but it has no internal sd card directory. External sd card is ok, though, as well as the system files. But cannot install from internal sd card (obviously), cannot format sdcard, or do anything that has something to do with sdcard. It gives an error "E:\ can't mount sdcard"

    When I connect the phone to the computer via USB, the phone "knows" that it is connected because the notification beep sounds and on Computer, it shows a new drive name (F:) but it says "Please Insert a disk into Removable Disk F.", which I believe, means it can detect it but cannot mount the storage.

    I can also use adb.

    So my questions are:
    -How do I get the touchscreen functionality back?
    -How can I enable my internal sd card to be mounted on the phone again?
    -(same as above) How do I enable USB Debugging from adb or recovery?

    I know I have a lot of issues on my phone but I would really appreciate it if you can help me. Thank you.
  2. ThomasErdbrik

    ThomasErdbrik New Member

    Aug 21, 2012
    There are lots of problem on this mobile.You can format this mobile from service center,than after must be work.
  3. Sponsored Advertisement

  4. Oklahomaguy

    Oklahomaguy Guest

    Sorry i can not answer all ur questions, but for that your internal SD card can not be mounted, few days ago, i upgraded my Galaxy S 2 to CIS 4.0.1 and the GS2 told me the sd card can be mounted, later, my consion helped me solve the problem by formatting the SD card.

Share This Page